Rabobank is experiencing performance issues - iDEAL transactions impacted

Incident Report for MultiSafepay

Resolved

Rabobank appears to have resolved their issue with processing iDEAL transactions. Since 19:00 CET we're seeing transactions at regular levels again, our team will continue to monitor the situation closely.
Posted Jan 27, 2021 - 19:22 CET

Investigating

Rabobank is reporting issues with processing iDEAL transactions. Our team is monitoring the situation closely.
Posted Jan 27, 2021 - 17:32 CET
This incident affected: Payments.