3D Secure elevated error rate
Incident Report for MultiSafepay
Resolved
The error rates have returned to regular values. Our team will continue to monitor the situation.
Posted May 19, 2022 - 16:37 CEST
Investigating
We are currently investigating an increase in the error rates for 3D Secure verification.
Posted May 19, 2022 - 16:24 CEST
This incident affected: Payments.