iDEAL performance issues with ING
Incident Report for MultiSafepay
Resolved
This incident has been resolved.
Posted Mar 30, 2020 - 15:54 CEST
Identified
ING has issues with handling iDEAL payments, other banks do not seem to be affected at this point. We're closely monitoring the situation and will update soon.
Posted Mar 30, 2020 - 15:30 CEST
This incident affected: Payments.